ファーム4.0を書き込むと動作しなくなる

かえうち フォーラム 【初心者歓迎】なんでも質問コーナー ファーム4.0を書き込むと動作しなくなる

14件の投稿を表示中 - 1 - 14件目 (全14件中)
  • 投稿者
    投稿
  • #5895
    adelie
    参加者

    先日、かえうち1にて、ファーム4.0書き込み時に動作しなくなってしまう問題が発生しました。
    具体的には以下の通りです。

    ・Windows 10 64bit上で発生、別のPCを用いても同様事象が再現
    ・かえうちカスタマイズ経由でカスタマイズモードにならない
    ・LEDも点灯または点滅しない
    ・デバイスマネージャ上は「! USB Composite Device」と表示される(かえうちカスタマイズフォルダ内のドライバでは更新不可)
    ・ケースを取り外してリセットしてもカスタマイズモードにならない

    これは、当該かえうち1がお亡くなりになったと言う事でしょうか……。
    対処方法等をありましたら、ご教示下さい。

    • このトピックはadelieが4ヶ月、 3週前に変更しました。
    • このトピックはadelieが4ヶ月、 3週前に変更しました。
    • このトピックはうぇぶしまが4ヶ月、 1週前に変更しました。
    #5901
    うぇぶしま
    キーマスター

    ファームウェアの書き込みに失敗したように考えられますが、リカバリー端子でもカスタマイズモードに切り替わらないことが不可解です。リカバリー端子をショートさせると、書き込まれているファームウェアの内容に関わらず強制的にカスタマイズモードに切り替わることが本来の動作です。

    念のため、以下をご確認ください。

    • リカバリー端子をショートさせる際に、PC側USB端子をPCに接続していますか?
    • PCへの接続時(ショート前)、デバイスマネージャー上に新規項目(USB Composite Device など)が表示されますか?
    • リカバリー端子をショートさせた直後、デバイスマネージャーの上記項目に変化はありませんか?
    • この返信は4ヶ月、 3週前にうぇぶしまが編集しました。
    #5904
    adelie
    参加者

    早速のコメント、ありがとうございます。
    すみません、うっかりPCに通電しないままショートさせていました。(いつもやり慣れている? 電池のついているマザボのBIOSリセットと同じつもりでやってしまいました。)
    → 通電時に短絡させると無事カスタマイズモードに入りました。

    とはいえ、4.0を書き込むとやはり動作しなくなり、リセットしないと書き込みすら出来なくなるようです。
    (Ver3台ならOKでした。4.0は書き込みには成功しますが、その後応答不能になります。)

    また、不可解なことにかえうち2で4.0のファームを入れてみたところ、以下の状況で動作しないことが分かりました。

    PC:hp 6200 pro small、自作PC(ASUS X-570-f)の両方で再現
    キーボード:REALFORCE SJ38DO、HHKB Professional proJP、DELLの附属ギーボードのいずれでも再現
    (LEDは点灯、デバイスマネージャ上でエラーは出ず。)
    ※ただし、面白いことにlogicool K400では動作します。

    2つ保有しているかえうち2のいずれもが同じ状況です。
    従って、かえうちカスタマイズを疑った方が良いでしょうか? (一度かえうちカスタマイズ6.0を再インストールしましたが、状況に変化はありません。カスタマイズファイルの不良も疑いましたが、プリセットを使っても同一事象は発生しています。(念のため使用しているカスタマイズファイルを添付しました。)

    以上、どうぞよろしくお願いします。

    • この返信は4ヶ月、 3週前にadelieが編集しました。
    #5915
    うぇぶしま
    キーマスター

    詳細なご報告ありがとうございます。
    ファームウェア4.0βは色々と不具合があるので、修正したファームウェアのリリースを予定しております。キーボードの組み合わせの情報も助かります。
    なお、かえうちカスタマイズ側の問題である可能性は低いです。

    #5919
    mattsun
    参加者

    かえうち2を利用していますが、
    ファーム3.xで問題なく利用できていたキーボードが、
    ファーム4.0Βでは利用できません。
    具体的には、全くキーボードが反応しなくなります。
    各種Lockキー(Scroll, Capsなど)を押下してもLockLEDも点灯せず全く無反応です。
    (3.xではLED点灯します)
    なお、3.xに戻すと正常動作します。

    調査資料採取必要であれば対応可能です。

    以上

    • この返信は4ヶ月、 1週前にmattsunが編集しました。
    • この返信は4ヶ月、 1週前にmattsunが編集しました。
    • この返信は4ヶ月、 1週前にmattsunが編集しました。
    • この返信は4ヶ月、 1週前にうぇぶしまが編集しました。
    #5927
    うぇぶしま
    キーマスター

    (かえうち1,2で差がある問題ではなさそうなので、トピックを統合しました。)

    4.0で動作しないときのLED点灯パターンを教えていただけますか? キーボードを接続してからPCに接続したとき、キーボードを接続せずにPCに接続したときの2パターン教えていただけると助かります。

    #5928
    mattsun
    参加者

    4.0で動作しない場合のLED点灯パターンを報告します。

    キーボードを接続してからPCに接続した場合
    ・赤→白
     (通常はこの状態で利用可能のはずですがどのキーも全く反応しません。)
    キーボードを接続せずにPCに接続した場合
    ・白点滅

    利用キーボードは ELECOM TK-FCM103

    以上です。

    #5939
    うぇぶしま
    キーマスター

    ご報告ありがとうございます。助かります。
    点灯パターンは問題ないにも関わらず、入力できないということですね。

    #6112
    takayan813
    参加者

    3.4までは正常に使用できるのですが、4.0及び4.1にて動作不能となりますので、
    ご報告いたします。

    使用中のキーボード:HHKB pro Hybrid US配列(ファームウェアA0.46)
    症状:全ての端末(2機種)で発生:OSはwindows 10 および ThinOS8.5_020

    ファームウェアの書換を正常に終了した後にキーボードが反応しなくなります。
    接続待機モードに切り替わった状態となり、キーが反応しないため、
    USB接続への切り替え等も出来ない状態です。
    ※メーカーマニュアルに記載されている(LEDインジケーター青色点灯状態)
    https://origin.pfultd.com/downloads/hhkb/manual/P3PC-6651-01.pdf

    3.4に戻すとキーボードはLEDインジケーターが消灯(接続状態)となり、入力が可能となります。

    この症状から回避する方法ございますでしょうか。

    #6117
    うぇぶしま
    キーマスター

    ご報告ありがとうございます。
    かえうちのLEDは、キーボードを接続したときと接続しないときで、それぞれどのように点きますか?

    #6127
    takayan813
    参加者

    コメントありがとうございます。

    4.1に上げた際は、
    キーボード未接続:白点滅、一度だけ赤点滅に切り替わり、すぐに白点滅に戻る
    キーボード接続 :赤点灯し、消灯の後、白点灯
    今回、ふと3.4を焼いた場合との違いを見つけました。
    4.1の場合のみ、書き換え成功した後、たった一度だけ白点灯から赤点灯に切り替わることがあります。
    (キーボードは接続したまま。)
    3.4を焼いた場合では、この赤点灯は有りませんでした。

    以上です。ご参考になれば幸いです。

    #6130
    うぇぶしま
    キーマスター

    ありがとうございます。
    ファームウェア4.1でUSB接続したときに、HHKBのLEDが青色点灯になり、「Fn+Control+0」でのUSB接続への切り替えを試みても何も変化がないということですね。

    4.1の場合のみ、書き換え成功した後、たった一度だけ白点灯から赤点灯に切り替わることがあります。
    (キーボードは接続したまま。)
    3.4を焼いた場合では、この赤点灯は有りませんでした。

    キーボードを接続したままの書き込みでは、
    赤弱点灯(書き換え中) → 赤点灯または2回程度の赤点滅(キーボード認識処理・数秒) → 白点灯(キーボード入力可)
    となるのが通常の動作です。どの部分の光り方が違いましたか?
    「一度だけ」とは何度も書き換えたうちの一度だけ起きたのか、書き換え時に毎回一度だけ赤点灯になるのか、どちらでしょうか?

    #6135
    takayan813
    参加者

    ありがとうございます。

    おっしゃる通りです。HHKBのキー自体が全く反応せず、Fn+Control+0のUSB接続切り替えも出来ません。
    ※3.4へのダウングレードを行うと、この作業すら不要でダウングレード成功後、そのままUSB接続になっており、タイピング可能な状態です。

    > どの部分の光り方が違いましたか?
    4.1へのアップグレード成功後は
    白点灯(キーボード入力可)
    の後に必ず、一度、赤ランプの点滅(その間白は無灯)があり、その後白点灯になります。

    3.4では
    赤弱点灯(書き換え中) → 赤点灯または2回程度の赤点滅(キーボード認識処理・数秒) → 白点灯(キーボード入力可)
    の、通りです。4.1βには上述の続きが生じます。

    > 書き換え時に毎回一度だけ赤点灯になる
    はい、4.1書き換え後は必ず
    白点灯(キーボード入力可)→赤点滅→白点灯以後そのまま。
    と、赤点滅が生じている状態です。

    #6140
    うぇぶしま
    キーマスター

    ご報告ありがとうございます。
    4.1での点灯パターンは見たことがありませんが、起きていることの推測ができるので調査の参考にいたします。

14件の投稿を表示中 - 1 - 14件目 (全14件中)
  • このトピックに返信するにはログインが必要です。